[プロファイルの新規・修正画面の操作説明]

以下、Mac OS X上で操作すると仮定して説明しますが、Windows/Linuxともに、ほとんど操作方法は同じです。

プロファイル選択画面

「ファイル」メニューから、「プロファイルを開く」を選択します。

screen1.png

すると、以下のような画面が開きます。

screen2.png

ここでプロファイルを選択すると、プロファイルの情報やサンプルピクチャがあれば表示され、右側の「新規」「修正」「削除」といったボタン操作が有効になります。

ただし、プロファイルが編集不可であれば「修正」はできず「照会」のみとなり、プロファイルが使用中であれば「削除」はできません。

新規プロファイル作成

「新規」ボタンを押下することで、テンプレートをもとに新しくプロファイルを作成する画面が開きます。

screen2a.png

初期状態では、「キャラクターなんとか機ver2.x」と「キャラクターなんとか機ver3」と同じフォルダ構造をもつプロファイルのテンプレートが用意されています。

(独自のフォルダ構造を作成した場合は、「テンプレートの作成」ボタンにより自分用のテンプレートを作成することもできます。)

新規プロファイルの作成(構造のコピー)

任意のプロファイルをひとつ選択した状態で「構造の複製」ボタンを押下すると、選択したプロファイルの構造をもとに新規のプロファイルを作成する画面が開きます。

基本タブの内容

screen3.png

設定ファイル

新規の場合は空欄です。既存のプロファイルを修正する場合は、character.xmlファイルがある場所を示すURIが表示されます。

この項目は編集不可です。

ID

このプロファイルに付ける名前です。英文字ではじまる英数字であれば自由に指定できます。

プロファイルのIDは、キャラクターセットにつける名前だと考えてよいです。たとえば、キャラクターなんとか機ver2のキャラクターセットであれば「default」としています。

もし、自分でレイヤーやカテゴリ構成を変えた場合や、同じ構成でも全く違う独自のパーツで構成されるキャラクターセットを作ったのであれば、それを識別できるように名前を変えます。

名前が違うことにより、インポートしたときに異なるキャラクターセットのパーツを混ぜてしまわないように注意を促すことが出来ます。

あまり気にしないのであれば「default」のままで不都合はありませんが、キャラクターセットが違うのであれば名前を変えておくことをお勧めします。

Rev

リビジョンです。IDがキャラクターセットの名前だとすると、Revは、そのカテゴリやレイヤーなどの構成情報が変わっているかどうかを示すものとなります。

英数字のバージョン番号を入れるものと考えていただければ良いと思います。

同じIDでも、レイヤーやカテゴリが変わっているとインポートする際には注意が必要になります。それを示すためのものです。

リビジョンはカテゴリやレイヤーの構成情報が変わると変更するように促されます。

あまり気にしないのであれば、自動に任せて問題ありません。

名前

プロファイルにつける名前です。日本語表記で問題ありません。

新規プロファイル作成時には、この名前のフォルダでキャラクターデータのフォルダが作成されます。(もし、同名のフォルダがすでにある場合は、その末尾に適当な番号が振られます。)

あとで変更することもできますが、フォルダ名は変わらないことに注意してください。

キャンバスのサイズ

画像のサイズを指定します。パーツ画像は、このサイズよりもはみ出た分はカットされます。

作者

このプロファイルを作成した作者名を指定できます。エクスポートする場合などに作者名を明示する場合や、誰が作成したキャラクターセットなのかを記録したい場合に使えます。

めんどくさいならば「名無し」で良いと思います。

説明

このプロファイルの説明を書きます。

めんどくさいならば、何も書かなくても問題ありません。

メモ書き程度と思っていただいて問題ありません。

カラーグループタブ

screen4.png

色の連動指定をする場合のグループ名を定義します。

順序は連動指定のドロップダウンで表示される順番です。

カテゴリタブ

screen5.png

カテゴリを定義します。

順序はカテゴリペインに表示される順番です。

パーツはカテゴリ単位に選択されます。

カテゴリ名

画面場に表示されるカテゴリ名です。

複数選択可

レ点がついている場合、そのカテゴリではパーツを複数選択できます。

表示行数

デフォルトで表示するパーツの行数です。この値にかかわらず、画面上で拡大・縮小は可能です。

使用しているレイヤー

このカテゴリを使用しているレイヤーの情報を表示します。(編集はできません。)

どのレイヤーからも使用されていないカテゴリは保存時に消去されます。

レイヤータブ

screen6.png

カテゴリごとのレイヤーを定義します。

カテゴリは複数の1つ以上のレイヤーから構成され、各レイヤーのディレクトリ上にあるファイル名がパーツ名として使用されます。

複数のレイヤーから構成されるパーツの場合、それらのファイル名はすべて同じにしておく必要があります。

レイヤー定義の順序は、カラーダイアログで表示されるレイヤータブの順序となります。(重ね合わせる順序は、重ね順で指定します。)

※ 本家キャラクターなんとか機と異なり、本アプリは、いずれかのレイヤーに画像があればすべてパーツとして認識します。

レイヤー名

レイヤー名は画面上で表示するレイヤーの名前となります。

カテゴリ

このレイヤーが属するカテゴリを、カテゴリタブで定義したカテゴリから選択します。

カラーグループ

このレイヤーが連動するカラーグループを、カラーグループタブで定義したカラーグループから選択します。

連動指定する必要がない場合はn/aを選択します。

重ね順

パーツを重ね合わせて表示するときの、重ね合わせる順序を指定します。

数字が小さい順に重ね合わせます。つまり、数字が小さいほど背面に配置され、大きいほど前面になります。

カラーモデル

HSB(色相・彩度・明度)か、HSY(色相・彩度・輝度)のいずれかのカラーモデルを選択できます。

HSBの場合、色相や彩度を変更した場合、輝度も変わりますが、HSYモデルの場合、色相や彩度を変更しても輝度は変化しません。

フォルダ

このレイヤーの画像を格納するディレクトリを指定します。

「フォルダを監視し、パーツ画像の変更を検知できるようにする」チェックボックス

このチェックボックスが有効である場合、ディレクトリ下のpngファイルが変更されたり追加されたり削除されたりすると、自動的にパーツリストを更新します。

「環境設定」の「ディレクトリ監視の有効・無効」が「false」になっている場合は、この設定にかかわらず監視はしません。 また、フォルダチェックの間隔は、「ディレクトリの監視間隔(mSec)」の設定時間ごととなります。

フォルダに直接ドロップしてパーツを増やす場合、あるいはパーツ画像を修正する場合などは、この設定が有効であれば自動的にパーツリストやプレビューを更新します。

フォルダに直接ドロップしたり画像ファイルに手を加える予定がなければ、無効にしておいても良いと思われます。

プリセットタブ

screen7.png

このプロファイルに設定する、お気に入り・プリセットの情報を設定します。

結論からいうと、あまり気にしなくて良い設定です。

新規の場合は空です。

既存のプロファイルを修正する場合は、お気に入りからプリセットに変更することができます。

プリセットとお気に入りの違いは内部的なもので、プリセットはcharacter.xml上に定義されており、お気に入りはfavorites.xmlに定義されています。

使う分には、あまり違いはありません。(ただし、プリセットにはデフォルトを指定でき、初回表示時に選択されるように設定できます。)

デフォルト

デフォルトのプリセットであることを示します。

デフォルトのプリセットは、そのキャラクターセットをはじめて開いたときに自動的に選択されるパーツセットのことです。

プリセット

お気に入り(favorites.xml)か、プリセット(character.xmlに同梱される)かの違いです。

パーツセット名

お気に入り・プリセットの名前です。

使用パーツ

このプリセット・お気に入りが使用しているパーツのリストを表示します。(編集不可)

お勧めリンクタブ

screen8.png

デフォルトで、「キャラクターなんとか機本家」と「パーツ保管庫」へのリンクが作成されますが、

独自のキャラクターセットである場合などには、これらのリンクのかわりに独自のリンクを追加するなどできます。

このリンクは「ヘルプ」メニューの下にある「お勧めリンク」に表示されます。

結論

もし、エクスポートして「キャラクターなんとかJ」を使う他のユーザに見てもらいたい場合には、 ID, Rev, 名前, 作者, 説明、および、お勧めリンクは、それなりに有効な情報になると思います。

自分でローカルマシン上で使用している分には、自分で状態を把握しているかぎり、これらは、あまり注意を払う必要はありません。

(もちろん、きちんと設定したほうが、いろいろ便利だとは思います。)

内部データの編集

もし、エクスポートして他のユーザに見てもらうプロファイルを作る場合には、画面からだけでは編集できない、いくつかの項目を調整したほうが良いかもしれません。

「キャラクターなんとかJ」を終了した状態で、character.xmlファイルを開きます。

カラーグループ、カテゴリ、レイヤー、プリセットなどには、すべてID項目が振られています。

画面上から編集すると、これらのIDは衝突を回避するためにランダムな値をもとに適当に割り当てられます。

これを意味のある英単語に書き換えると、よりわかりやすいデータとなります。

(デフォルトのキャラクター定義は、ランダムなIDではなく、意味のある単語にしています。)

お気に入りやプリセットは、レイヤーやカテゴリの名前ではなく、IDを参照しているため、IDを変更した場合は、お気に入りやプリセットも変更する必要があります。