チケット #32511

17.0.11 G3 version not opeing on G3s

登録: 2013-12-04 04:37 最終更新: 2014-03-12 22:06

報告者:
(匿名)
担当者:
チケットの種類:
状況:
完了
コンポーネント:
マイルストーン:
(未割り当て)
優先度:
9 - 最高
重要度:
7
解決法:
修正済み

詳細

Cannot open the latest G3 version 17.0.11 on any of my G3 machines. 17.0.2 worked fine.

添付ファイルリスト

添付ファイルはありません

チケットの履歴 (10 件中 3 件表示)

2013-12-04 04:37 更新者: None
  • 新しいチケット "17.0.11 G3 version not opeing on G3s" が作成されました
2013-12-04 23:23 更新者: t_mrc-ct
  • 担当者(未割り当て) から t_mrc-ct に更新されました
  • 重要度5 - 中 から 7 に更新されました
  • 優先度5 - 中 から 7 に更新されました
コメント

I can't test G3 build on G3 machine, because I don't have G3 machine... So I need your help to resolve this issue.

Can you check the following things?:

1. When you try to startup TenfourbirdG3 17.0.11, error messages related to Tenfourbird (Thunderbird) are displayed on Console app? (/Applications/Utilities/Console)

2. version 24.1.0 is runnable on G3 machine?

3. Can you find out last runnable version (17.0.3 - 17.0.10)? (If there is spare time)

Regards.

2013-12-06 01:58 更新者: None
コメント

.

Hi

Although not my original-post bug-report, I can offer what Console says on mine when failing to launch :


2013-12-04 20:52:58.022 Terminal[206] CFLog (22): Cannot find function pointer New_JackRouterPlugIn for factory 7CB18864-927D-48B5-904C-CCFBCFBC7ADD in CFBundle/CFPlugIn 0x4bdc80 </Library/Audio/Plug-Ins/HAL/JackRouter.plugin> (bundle, not loaded) 

DUDebug DU Notification received: _DU_DiskSelectionChangedNotification with object DUWindowController (0x425280) 

DUDebug DU Notification received: _DU_DiskSelectionChangedNotification with object DUWindowController (0x425280) 

XPCOMGlueLoad error 4:0 for file /Applications/TenfourbirdG3/TenfourbirdG3-v17.0.11.app/Contents/MacOS/libxpcom.dylib: 

Library not loaded: @executable_path/XUL 

  Referenced from: /Applications/TenfourbirdG3/TenfourbirdG3-v17.0.11.app/Contents/MacOS/libxpcom.dylib 

  Reason: no suitable image found.  Did find: 
    /Applications/TenfourbirdG3/TenfourbirdG3-v17.0.11.app/Contents/MacOS/XUL: incompatible cpu-subtype 
    /Applications/TenfourbirdG3/TenfourbirdG3-v17.0.11.app/Contents/MacOS/XUL: incompatible cpu-subtype
 

.

PowerBook Pismo G3/500 1024 MB Tiger 10.4.11

Hope this helps. :)

TIA

.

2013-12-06 02:07 更新者: None
コメント

.

oh, sorry, Q2 and Q3..

I haven't started with any version 24s, neither Tenfourbird nor TenFourFox.

But TFB version 17.0.7 seemed to work fine, thanks.

PowerBook Pismo G3/500 1024 MB Tiger 10.4.11

Hope this helps. :)

TIA

2013-12-07 17:55 更新者: t_mrc-ct
  • 優先度7 から 9 - 最高 に更新されました
コメント

Thank you for checking.

The following report seems similar to this problem: Crash on G3: dyld incompatible cpu-subtype

G3 binaries should have cpu subtype 9 (G3) or cpu subtype 0 (General).

But v17.0.11's XUL and js libraries's cpu-subtype is 10 (7400).

If crash is caused by this cpu-subtype issue, v17.0.9 may also runnable on G3 machine.

v24.1.0b1 also has this issue. So I should fix this before G3 v24.2.0 release.

But I still not figure out why XUL and js have different cpu-subtype from others...

2013-12-08 23:17 更新者: t_mrc-ct
コメント

I found cause of this bug (maybe ...).

Since Tenfourbird v17.0.10, I have upgraded libffi's ppc darwin port to v3.0.13. This upgrade resolves js-ctypes's function call bug. (passed: toolkit/components/ctypes/tests/unit/test_jsctypes.js)

But libffi v3.0.13 have the code specifies supported CPU as ppc7400 (G4). So G3 build crashed.

Solution is simple. Remove code that specifies supported CPU.

libffi's assembly codes don't use altivec. So It may run on G3 without modification.

I released Tenfourbird 17.0.11.1 for PowerPC G3: http://sourceforge.jp/projects/tenfourbird/releases/60011

It contains patch of this bug. Please test it on G3 machine. (I can't test on G3...)

Thanks.

2013-12-14 16:25 更新者: None
コメント

I sent thru this bug:

"Cannot open the latest G3 version 17.0.11 on any of my G3 machines. 17.0.2 worked fine."

I have downloaded 17.0.11.1 and it does open up and I was able to create email accounts. The G3 that it is working on is a G3 Pismo 400. This is one of the same G3s it did not work on earlier.

I will test on other G3s and report back.

Thanks for your efforts on this.

Rick

2013-12-16 03:05 更新者: None
コメント

I sent thru this bug:

"Cannot open the latest G3 version 17.0.11 on any of my G3 machines. 17.0.2 worked fine."

I have installed 17.0.11.1 on a G3 Pismo 500 and it also opens and installs with no problem.

Will let u know about further installs.

2013-12-16 17:33 更新者: t_mrc-ct
  • 解決法なし から 修正済み に更新されました
コメント

Thank you for testing. I'm happy to hear good result. :-)

This fix also contains in v24.2.0. v24.2.0 will work on G3 if there are no other crash bug. (But there may be performance issue...)

v24.2.0 will release before next weekend. (I hope so...)

Thanks.

2014-03-12 22:06 更新者: t_mrc-ct
  • チケット完了時刻2014-03-12 22:06 に更新されました
  • 状況オープン から 完了 に更新されました
  • コンポーネント(未割り当て) から Tenfourbird に更新されました

編集

ログインしていません。ログインしていない状態では、コメントに記載者の記録が残りません。 » ログインする