rename pushback to concat
The stack.pushback() function is concat, call it that.
Nice opportunity to use the VSCode auto-renaming facility.
It's removed from the code but still appears in some of the docs.
I believe this is done except for one or two places in the docs. Find and correct those.
find docs -type f -print0 | xargs --null grep -n pushback | sort | less -S