• R/O
  • HTTP
  • SSH
  • HTTPS

コミット

タグ
未設定

よく使われているワード(クリックで追加)

javac++androidlinuxc#windowsobjective-ccocoa誰得qtpythonphprubygameguibathyscaphec計画中(planning stage)翻訳omegatframeworktwitterdomtestvb.netdirectxゲームエンジンbtronarduinopreviewer

Tera Termの個人的な作業用リポジトリ


コミットメタ情報

リビジョンaa30d75fceec8d2f077081d57c3e4268f4b6bcf6 (tree)
日時2023-10-15 11:04:30
作者nmaya <nmaya@user...>
コミッターnmaya

ログメッセージ

Tera Term 4.95 で 脆弱性の対応をしたことを変更履歴に追記 (JVN#06770361, CVE-2017-2193)

ticket: #48843
MFT: r10994

git-svn-id: svn+ssh://svn.osdn.net/svnroot/ttssh2/branches/4-stable@10995 f5f01b69-1e22-0410-acbf-894ab4bd6246

変更サマリ

差分

--- a/doc/en/html/about/history.html
+++ b/doc/en/html/about/history.html
@@ -528,6 +528,7 @@
528528 <ul>
529529 <li>upgraded TTSSH to <a href="#ttssh_2.81">2.81</a>.</li>
530530 <li>upgraded Oniguruma to 6.2.0.</li>
531+ <li>upgraded the version of Inno Setup that is used for the installer. Because a vulnerability of Inno Setup has been fixed. (<a href="https://ttssh2.osdn.jp/SA/JVN06770361.html" target="_blank">Announce from TeraTerm Project</a>, <a href="https://jrsoftware.org/files/is5.5-whatsnew.htm#5.5.9" target="_blank">Inno Setup Revision History</a>, <a href="https://jvn.jp/jp/JVN06770361/" target="_blank">JVN#06770361</a>, <a href="https://nvd.nist.gov/vuln/detail/CVE-2017-2193" target="_blank">CVE-2017-2193</a>)</li>
531532 <li>NOTICE: The installer no longer support Windows 95, 98, Me and NT 4.0. Please use the zip archive version on these Windows.</li>
532533 </ul>
533534 </li>
--- a/doc/ja/html/about/history.html
+++ b/doc/ja/html/about/history.html
@@ -528,6 +528,7 @@
528528 <ul>
529529 <li><a href="#ttssh_2.81">TTSSH(2.81)</a>へ差し替えた。</li>
530530 <li>Oniguruma 6.2.0へ差し替えた。</li>
531+ <li>インストーラに使用している Inno Setup の脆弱性が修正されたため、Inno Setup のバージョンを上げました。(<a href="https://ttssh2.osdn.jp/SA/JVN06770361.html" target="_blank">TeraTerm Project のアナウンス</a>, <a href="https://jrsoftware.org/files/is5.5-whatsnew.htm#5.5.9" target="_blank">Inno Setup Revision History</a>, <a href="https://jvn.jp/jp/JVN06770361/" target="_blank">JVN#06770361</a>, <a href="https://nvd.nist.gov/vuln/detail/CVE-2017-2193" target="_blank">CVE-2017-2193</a>)</li>
531532 <li>インストーラは Windows 95, 98, Me, NT 4.0 をサポートしなくなりました。これらの OS では zip アーカイブ版を展開して使用できます。</li>
532533 </ul>
533534 </li>