フォーラム: ヘルプ (スレッド #37246)

Always an xml-error-message from "updates.xul" (2015-10-29 16:59 by Jens #77089)

Hello!

I'm from Germany and i'm using the Tenfourbird 38.3.0 for PowerPC 7450 (with German-Langpack on a Silver G4 with OS X 10.4.11).

After starting the "Bird" every day there is an error-message in the background:
XML-Verarbeitungsfehler: Nicht definierte Entität
Adresse: chrome://mozapps/content/update/updates.xul
Zeile Nr. 88, Spalte 5: <updateheader label="&manualUpdate2.title;"/>
----^

Here is the original picture from the error-message-window:
http://up.picr.de/23542363vv.jpg

Did you know the problem or is it unique on my mac? Is there any solution/patch for the error?

Thx for help and keep up your great work
Jens

メッセージ #77089 への返信×

Wiki文法は使えません
ログインしていません。投稿を区別するために投稿者のニックネームをつけてください(ニックネームの一意性は保証されません。全く別の人も同じ名前を利用することが可能ですので本人であることの特定には利用できません。本人であることを保証したい場合にはログインして投稿を行なってください)。 ログインする

Re: Always an xml-error-message from &quot;updates.xul&quot; (2015-11-01 18:08 by t_mrc-ct #77098)

Thank you for reporting the issue.

I've using German-langpack few days. But I have not experience such trouble yet...
It look like XUL cache problem. So Resetting XUL cache may help you.

Could you try the following steps?

1. Open the Config Editor carefully. (Tenfourbird > Preferences > Advanced button > General tab > Config Editor... button)
2. Search nglayout.debug.disable_xul_cache
3. If there is no such preference, add it. (Context menu: New -> Boolean, Input preference name)
4. Set it to true.
5. Restart Tenfourbird.
6. Open the Config Editor.
7. Search nglayout.debug.disable_xul_cache
8. Reset it. (Context menu: Reset)

Regards.

[Reply To Message #77089]
> Hello!
>
> I'm from Germany and i'm using the Tenfourbird 38.3.0 for PowerPC 7450 (with German-Langpack on a Silver G4 with OS X 10.4.11).
>
> After starting the "Bird" every day there is an error-message in the background:
> XML-Verarbeitungsfehler: Nicht definierte Entität
> Adresse: chrome://mozapps/content/update/updates.xul
> Zeile Nr. 88, Spalte 5: <updateheader label="&manualUpdate2.title;"/>
> ----^
>
> Here is the original picture from the error-message-window:
> http://up.picr.de/23542363vv.jpg
>
> Did you know the problem or is it unique on my mac? Is there any solution/patch for the error?
>
> Thx for help and keep up your great work
> Jens
#77089 への返信

メッセージ #77098 への返信×

Wiki文法は使えません
ログインしていません。投稿を区別するために投稿者のニックネームをつけてください(ニックネームの一意性は保証されません。全く別の人も同じ名前を利用することが可能ですので本人であることの特定には利用できません。本人であることを保証したい場合にはログインして投稿を行なってください)。 ログインする

Re: Always an xml-error-message from &amp;quot;updates.xul&amp;quot; (2015-11-04 18:36 by Jens #77125)

Hello from Germany!

Thank you for the quick help and the solution-trick.
I followed the steps you have written, but the error-message is also there.

Regards
Jens

[Reply To Message #77098]
> Thank you for reporting the issue.
>
> I've using German-langpack few days. But I have not experience such trouble yet...
> It look like XUL cache problem. So Resetting XUL cache may help you.
>
> Could you try the following steps?
>
> 1. Open the Config Editor carefully. (Tenfourbird > Preferences > Advanced button > General tab > Config Editor... button)
> 2. Search nglayout.debug.disable_xul_cache
> 3. If there is no such preference, add it. (Context menu: New -> Boolean, Input preference name)
> 4. Set it to true.
> 5. Restart Tenfourbird.
> 6. Open the Config Editor.
> 7. Search nglayout.debug.disable_xul_cache
> 8. Reset it. (Context menu: Reset)
>
> Regards.
>
> [Reply To Message #77089]
> > Hello!
> >
> > I'm from Germany and i'm using the Tenfourbird 38.3.0 for PowerPC 7450 (with German-Langpack on a Silver G4 with OS X 10.4.11).
> >
> > After starting the "Bird" every day there is an error-message in the background:
> > XML-Verarbeitungsfehler: Nicht definierte Entität
> > Adresse: chrome://mozapps/content/update/updates.xul
> > Zeile Nr. 88, Spalte 5: <updateheader label="&manualUpdate2.title;"/>
> > ----^
> >
> > Here is the original picture from the error-message-window:
> > http://up.picr.de/23542363vv.jpg
> >
> > Did you know the problem or is it unique on my mac? Is there any solution/patch for the error?
> >
> > Thx for help and keep up your great work
> > Jens

#77098 への返信

メッセージ #77125 への返信×

Wiki文法は使えません
ログインしていません。投稿を区別するために投稿者のニックネームをつけてください(ニックネームの一意性は保証されません。全く別の人も同じ名前を利用することが可能ですので本人であることの特定には利用できません。本人であることを保証したい場合にはログインして投稿を行なってください)。 ログインする

Re: Always an xml-error-message from &amp;amp;quot;updates.xul&amp;amp;quot; (2015-11-06 20:21 by t_mrc-ct #77132)

Umm... Can you try the following procedure?

[Tenfourbird reinstallation]
1. Delete Tenfourbird app file
2. Uncompress Tenfourbird***.zip
3. Put new Tenfourbird app file

[Langpack reinstallation]
1. Uninstall Langpack
2. Restart Tenfourbird
3. Install Langpack
4. Restart Tenfourbird

Could you test en-US locale, if you still get the error-message? (general.useragent.local = en-US)

Thanks.

[Reply To Message #77125]
> Hello from Germany!
>
> Thank you for the quick help and the solution-trick.
> I followed the steps you have written, but the error-message is also there.
>
> Regards
> Jens
#77125 への返信

メッセージ #77132 への返信×

Wiki文法は使えません
ログインしていません。投稿を区別するために投稿者のニックネームをつけてください(ニックネームの一意性は保証されません。全く別の人も同じ名前を利用することが可能ですので本人であることの特定には利用できません。本人であることを保証したい場合にはログインして投稿を行なってください)。 ログインする

Re: Always an xml-error-message from &amp;amp;quot;updates.xul&amp;amp;quot; (2015-11-10 21:11 by t_mrc-ct #77154)

Now, I can reproduce this bug!

I'm trying to figure out where is the cause of this bug.

You can prevent this error in en-US locale.

Thanks.

[Reply To Message #77125]
> Hello from Germany!
>
> Thank you for the quick help and the solution-trick.
> I followed the steps you have written, but the error-message is also there.
>
> Regards
> Jens
>
> [Reply To Message #77098]
> > Thank you for reporting the issue.
> >
> > I've using German-langpack few days. But I have not experience such trouble yet...
> > It look like XUL cache problem. So Resetting XUL cache may help you.
> >
> > Could you try the following steps?
> >
> > 1. Open the Config Editor carefully. (Tenfourbird > Preferences > Advanced button > General tab > Config Editor... button)
> > 2. Search nglayout.debug.disable_xul_cache
> > 3. If there is no such preference, add it. (Context menu: New -> Boolean, Input preference name)
> > 4. Set it to true.
> > 5. Restart Tenfourbird.
> > 6. Open the Config Editor.
> > 7. Search nglayout.debug.disable_xul_cache
> > 8. Reset it. (Context menu: Reset)
> >
> > Regards.
> >
> > [Reply To Message #77089]
> > > Hello!
> > >
> > > I'm from Germany and i'm using the Tenfourbird 38.3.0 for PowerPC 7450 (with German-Langpack on a Silver G4 with OS X 10.4.11).
> > >
> > > After starting the "Bird" every day there is an error-message in the background:
> > > XML-Verarbeitungsfehler: Nicht definierte Entität
> > > Adresse: chrome://mozapps/content/update/updates.xul
> > > Zeile Nr. 88, Spalte 5: <updateheader label="&manualUpdate2.title;"/>
> > > ----^
> > >
> > > Here is the original picture from the error-message-window:
> > > http://up.picr.de/23542363vv.jpg
> > >
> > > Did you know the problem or is it unique on my mac? Is there any solution/patch for the error?
> > >
> > > Thx for help and keep up your great work
> > > Jens
>
#77125 への返信

メッセージ #77154 への返信×

Wiki文法は使えません
ログインしていません。投稿を区別するために投稿者のニックネームをつけてください(ニックネームの一意性は保証されません。全く別の人も同じ名前を利用することが可能ですので本人であることの特定には利用できません。本人であることを保証したい場合にはログインして投稿を行なってください)。 ログインする

Re: Always an xml-error-message from &amp;amp;amp;quot;updates.xul&amp;amp;amp;quot; (2015-11-12 21:17 by t_mrc-ct #77160)

Bugfixed langpacks (38.4.0) are released.
https://osdn.jp/projects/tenfourbird/releases/64020

Cause of this bug is that I did forget apply one patch :-<

Autoupdate of new langpacks are started in few days.

Regards.
#77154 への返信

メッセージ #77160 への返信×

Wiki文法は使えません
ログインしていません。投稿を区別するために投稿者のニックネームをつけてください(ニックネームの一意性は保証されません。全く別の人も同じ名前を利用することが可能ですので本人であることの特定には利用できません。本人であることを保証したい場合にはログインして投稿を行なってください)。 ログインする

Re: Always an xml-error-message from &amp;amp;amp;amp;quot;updates.xul&amp;amp;amp;amp;quot; (2015-11-16 19:27 by Jens #77191)

Great!

Thank you for the quick help.

Greetings from Germany
Jens

[Reply To Message #77160]
> Bugfixed langpacks (38.4.0) are released.
> https://osdn.jp/projects/tenfourbird/releases/64020
>
> Cause of this bug is that I did forget apply one patch :-<
>
> Autoupdate of new langpacks are started in few days.
>
> Regards.
#77160 への返信

メッセージ #77191 への返信×

Wiki文法は使えません
ログインしていません。投稿を区別するために投稿者のニックネームをつけてください(ニックネームの一意性は保証されません。全く別の人も同じ名前を利用することが可能ですので本人であることの特定には利用できません。本人であることを保証したい場合にはログインして投稿を行なってください)。 ログインする