チケット #40264

Upgrading mingw-get (after installing with mingw-get-setup) installs an older version

登録: 2020-03-17 19:21 最終更新: 2020-03-18 03:03

報告者:
担当者:
チケットの種類:
状況:
完了
コンポーネント:
マイルストーン:
(未割り当て)
優先度:
5 - 中
重要度:
5 - 中
解決法:
修正済み
ファイル:
なし
投票
点数: 0
No votes
0.0% (0/0)
0.0% (0/0)

詳細

If I download the installer from OSDN.net (https://osdn.net/projects/mingw/downloads/68260/mingw-get-setup.exe/), and run it, accepting the defaults, I end up with the MinGW Installation Manager GUI.

If I exit the Installation Manager without doing anything, and run:

    C:\MinGW\bin\mingw-get --version
I get:
    mingw-get version 0.6.3-pre-20170905-1
    [...]

If I run:

    C:\MinGW\bin\mingw-get update
    C:\MinGW\bin\mingw-get upgrade
and then run "C:\MinGW\bin\mingw-get --version" again, I get:
    mingw-get version 0.6.2-beta-20131004-1
    [...]

If before exiting the Installation Manager, I selected from the "Installation" menu "Update Catalogue", then "Mark All Upgrades", then "Apply Changes", version 0.6.2-beta-20131004-1 would get installed, as well.

チケットの履歴 (2 件中 2 件表示)

2020-03-17 19:21 更新者: tamir_evan
  • 新しいチケット "Upgrading mingw-get (after installing with mingw-get-setup) installs an older version" が作成されました
2020-03-18 03:03 更新者: keith
  • 状況オープン から 完了 に更新されました
  • 担当者(未割り当て) から keith に更新されました
  • 解決法なし から 修正済み に更新されました
コメント

Indeed, that doesn't seem correct, thank you. Sure enough, the online catalogue doesn't reflect the correct publication status, for mingw-get. I've just pushed a correction; give it up to an hour, to propagate to the mirrors, and it should then be correct.

添付ファイルリスト

添付ファイルはありません

編集

このチケットにコメントを追加するには、ログインが必要です » ログインする