フォーラム: ・フォーラム (スレッド #39151)

プラグインのインストールについて (2018-01-25 19:16 by bcdmart #80675)

PDEプロジェクトのテンプレート"Hello, World Command"を作ってみました。
これをExportして、生成されたファイル(PluginTest_1.0.0.201801251852.jar)をpluginsフォルダ配下(C:\pleiades-4.7.1\pleiades\eclipse\plugins)に設置して、Eclipseを再起動したところ、作ったプラグインはインストールされません。
一方、英語版のEclipse (eclipse-committers-oxygen-1a-win32-x86_64)で同じ手順を行ったところ、作ったプラグインはインストールされました。
pleiadesにプラグインをインストールする場合、別の手順で行うものなのでしょうか?

よろしくお願いします。

メッセージ #80675 への返信×

ログインしていません。投稿を区別するために投稿者のニックネームをつけてください(ニックネームの一意性は保証されません。全く別の人も同じ名前を利用することが可能ですので本人であることの特定には利用できません。本人であることを保証したい場合にはログインして投稿を行なってください)。 ログインする

Re: プラグインのインストールについて (2018-01-25 19:28 by cypher256 #80676)

プラグインを更新した場合は、-clean を付けて起動してください。
#80675 への返信

メッセージ #80676 への返信×

ログインしていません。投稿を区別するために投稿者のニックネームをつけてください(ニックネームの一意性は保証されません。全く別の人も同じ名前を利用することが可能ですので本人であることの特定には利用できません。本人であることを保証したい場合にはログインして投稿を行なってください)。 ログインする

Re: プラグインのインストールについて (2018-01-25 19:30 by cypher256 #80677)

ご存知かもしれませんが、Pleiades に関係なく、現在の Eclipse は plugins へ
手動配置した場合の正常動作は保証されていません。
手動で配置する場合は dropins に配置する必要があります。
#80675 への返信

メッセージ #80677 への返信×

ログインしていません。投稿を区別するために投稿者のニックネームをつけてください(ニックネームの一意性は保証されません。全く別の人も同じ名前を利用することが可能ですので本人であることの特定には利用できません。本人であることを保証したい場合にはログインして投稿を行なってください)。 ログインする

Re: プラグインのインストールについて (2018-01-26 10:16 by bcdmart #80680)

[メッセージ #80677 への返信]

返信ありがとうございます。

> 手動で配置する場合は dropins に配置する必要があります。
知りませんでした。(申し遅れましたが、私のEclipse歴 半年です)

以下のフォルダに配置しましたが、プラグインはインストールできませんでした。
C:\pleiades-4.7.1\pleiades\eclipse\dropins\mytool\eclipse\plugins\test_1.0.0.201801260848.jar

英語版も同様に以下に設置すると、こちらはプラグインインストールできました。
C:\eclipse-committers-oxygen-1a-win32-x86_64\dropins\mytool\eclipse\plugins\test_1.0.0.201801260848.jar

# 起動は -cleanオプションで行っています。
#80677 への返信

メッセージ #80680 への返信×

ログインしていません。投稿を区別するために投稿者のニックネームをつけてください(ニックネームの一意性は保証されません。全く別の人も同じ名前を利用することが可能ですので本人であることの特定には利用できません。本人であることを保証したい場合にはログインして投稿を行なってください)。 ログインする

Re: プラグインのインストールについて (2018-01-26 10:23 by cypher256 #80681)

うーん。ちょっと分からないですね。
eclipse.ini の下記 2 行の先頭に # を付けてコメントアウトして
Pleiades を無効にして -clean 起動するなどして試してみてください。

-Xverify:none
-javaagent:...

あと、Pleiades の readme.txt を参照して、
キャッシュディレクトリを削除するなどがあります。
#80680 への返信

メッセージ #80681 への返信×

ログインしていません。投稿を区別するために投稿者のニックネームをつけてください(ニックネームの一意性は保証されません。全く別の人も同じ名前を利用することが可能ですので本人であることの特定には利用できません。本人であることを保証したい場合にはログインして投稿を行なってください)。 ログインする

Re: プラグインのインストールについて (2018-01-26 11:15 by bcdmart #80682)

[メッセージ #80681 への返信]
返信ありがとうございます。

Pleiades を無効にしてもキャッシュディレクトリを削除してもダメでした。

もう少し調べてみます。
何かわかりましたら、展開します。

#80681 への返信

メッセージ #80682 への返信×

ログインしていません。投稿を区別するために投稿者のニックネームをつけてください(ニックネームの一意性は保証されません。全く別の人も同じ名前を利用することが可能ですので本人であることの特定には利用できません。本人であることを保証したい場合にはログインして投稿を行なってください)。 ログインする

Re: プラグインのインストールについて (2018-01-29 09:33 by bcdmart #80701)

C/C++版の「pleiades-4.7.2-cpp-win-64bit-jre_20171225」では、プラグインがインストールできることを確認できました。

前述のインストールできなかったバージョンは、Ultimate版の「pleiades-4.7.1-ultimate-win-64bit-jre_20171019」です。

真の原因はわかりませんが、pleiades-4.7.1-ultimate版とは相性がわるかったようです。
#80682 への返信

メッセージ #80701 への返信×

ログインしていません。投稿を区別するために投稿者のニックネームをつけてください(ニックネームの一意性は保証されません。全く別の人も同じ名前を利用することが可能ですので本人であることの特定には利用できません。本人であることを保証したい場合にはログインして投稿を行なってください)。 ログインする

Re: プラグインのインストールについて (2018-01-29 15:18 by bcdmart #80703)

追加情報ですが、最新の「pleiades-4.7.2-ultimate-win-64bit-jre_20171225」 ではプラグインをインストールできました。

以前使用していた「pleiades-4.7.1-ultimate-win-64bit-jre_20171019」に、プラグインインストールに関する何らかの問題があったのかもしれません。

#80701 への返信

メッセージ #80703 への返信×

ログインしていません。投稿を区別するために投稿者のニックネームをつけてください(ニックネームの一意性は保証されません。全く別の人も同じ名前を利用することが可能ですので本人であることの特定には利用できません。本人であることを保証したい場合にはログインして投稿を行なってください)。 ログインする