話題(スレッド): Pleiades4.6.3/4.7.1-PHPについて

Pleiades4.6.3/4.7.1-PHPについて (2017-10-18 16:05, Yui.A, #80369)

Pleiades4.6.3以降、PHPパッケージにはComposerプラグイン等が同梱されているかと思いますが、こちらが正常に動作していないように思います。

4.6.3/4.7.1のPHPパッケージと4.7.1のUltパッケージを確認しましたが、

・Ultパッケージと比較してPHPパッケージにはPDT Composer UI プラグインが存在していないように見える

・PHPパッケージでありながらPDT本体がインストール済みソフトウェアに存在しない(上位依存関係にあるプラグインが存在していないように思います)

・PDT本体が動作していない為、それに依存する
 >PDT Composer Support
 >PDT PHPUnit Support
が読み込まれていない(ように見える)

以上の点がありました。また、新規ソフトウェアインストールからPDT本体や同Composer Supportを指定して導入すると正常に動作します。
Ult版では正常に動作していますので、PHP版へのダウンサイジングで欠損等が起きていないでしょうか?
それとも、この状態で想定通り正常なのでしょうか。
確認をお願いいたします。

メッセージ #80369 への返信×

ログインしていません。投稿を区別するために投稿者のニックネームをつけてください(ニックネームの一意性は保証されません。全く別の人も同じ名前を利用することが可能ですので本人であることの特定には利用できません。本人であることを保証したい場合にはログインして投稿を行なってください)。 ログインする

Re: Pleiades4.6.3/4.7.1-PHPについて (2017-10-18 16:45, Yui.A, #80370)

記載漏れですが、
OS:Windows10 64bit
PleiadesはすべてWindows 64bit Fullパッケージです。
#80369 への返信

メッセージ #80370 への返信×

ログインしていません。投稿を区別するために投稿者のニックネームをつけてください(ニックネームの一意性は保証されません。全く別の人も同じ名前を利用することが可能ですので本人であることの特定には利用できません。本人であることを保証したい場合にはログインして投稿を行なってください)。 ログインする

Re: Pleiades4.6.3/4.7.1-PHPについて (2017-10-18 21:38, cypher256, #80371)

なぜか Windows 版のみ依存関係として C/C++ プラグインが必要になっていました。
取り急ぎ下記にアップロードしました。
後でリリースします。

http://mergedoc.globalbase.org/archive/pleiades/4.7/pleiades-4.7.1-php-win-64bit-jre_20171019.zip

4.6.3 は更新せずに注意書きします。
#80369 への返信

メッセージ #80371 への返信×

ログインしていません。投稿を区別するために投稿者のニックネームをつけてください(ニックネームの一意性は保証されません。全く別の人も同じ名前を利用することが可能ですので本人であることの特定には利用できません。本人であることを保証したい場合にはログインして投稿を行なってください)。 ログインする