話題(スレッド): プラグインのマニフェスト・エディターでエラー

プラグインのマニフェスト・エディターでエラー (2017-04-17 11:45, nishi, #79712)

Win7 64bit java1.8.0_121環境で、一つ前の4.6.2から
Pleiades All in One 4.6.3.v20170323にバージョンを上げたところ
プラグインプロジェクトにおいてそれまで表示されていた
MANIFEST.MFやplugin.xmlをマニフェスト・エディターで開く際に
以下のエラーが発生するようになりました。
--------------------------------------
未処理のイベント・ループ例外
org.eclipse.swt.SWTException: Graphic is disposed
at org.eclipse.swt.SWT.error(SWT.java:4533)
at org.eclipse.swt.SWT.error(SWT.java:4448)
at org.eclipse.swt.SWT.error(SWT.java:4419)
at org.eclipse.swt.graphics.Image.getBounds(Image.java:1396)
--------------------------------------
試しにeclipse.iniからpleiades.jarを外した所、plugin.xmlを正常に開くことができました。

メッセージ #79712 への返信×

ログインしていません。投稿を区別するために投稿者のニックネームをつけてください(ニックネームの一意性は保証されません。全く別の人も同じ名前を利用することが可能ですので本人であることの特定には利用できません。本人であることを保証したい場合にはログインして投稿を行なってください)。 ログインする

Re: プラグインのマニフェスト・エディターでエラー (2017-04-18 22:12, cypher256, #79722)

翻訳リソースに含まれる HTML タグの処理で問題が発生していたため、
Pleiades 本体を修正しました。
最新版ダウンロードからダウンロードできます。

1.7.26 - 2017.04.18
・[FORUM#79712] Eclipse で MANIFEST.MF や plugin.xml が開けない問題に対応

Pleiades All in One に適用する場合は、ダウンロードした pleiades.zip を解凍し、
eclipse ディレクトリの dropins/MergeDoc/eclipse/
に上書きまたは入れ替えてください。

後日、Pleiades All in One 4.6.3 にも反映し、リリースする予定です。
#79712 への返信

メッセージ #79722 への返信×

ログインしていません。投稿を区別するために投稿者のニックネームをつけてください(ニックネームの一意性は保証されません。全く別の人も同じ名前を利用することが可能ですので本人であることの特定には利用できません。本人であることを保証したい場合にはログインして投稿を行なってください)。 ログインする