フォーラム: 【御礼は忘れずに】linuxBean質問スレッド【ハンドルネーム必須】 (スレッド #35655)

IME強化辞書がインストールできない (2014-06-27 12:40 by inaho #73637)

linux Beanを古いPCの再生に使わせて頂いています。

linux Bean 14.04-140618をインストールしてソフトウェアの更新とlinux Bean スクリプトの更新を行った状態で、linux Bean 設定ウィザードからIME強化辞書をインストールしようとすると、Terminal上に下記のメッセージが出てインストールに失敗します。
このメッセージを見るとパッケージ化に失敗しているようですが、どのようにすればインストールできるのでしょうか?
よろしくお願いします。

以下はTerminalの出力の抜粋です。

ソースの解凍に成功しました。
ソースをコンパイルしてパッケージ化します。
debuild: fatal error at line 632:
cannot find readable debian/changelog anywhere!
Are you in the source code tree?
パッケージ化に失敗しました。
dpkg: error processing archive mozc*.deb (--install):
アーカイブにアクセスできません: そのようなファイルやディレクトリはありません
dpkg: error processing archive fcitx*.deb (--install):
アーカイブにアクセスできません: そのようなファイルやディレクトリはありません
処理中にエラーが発生しました:
mozc*.deb
fcitx*.deb
インストールに失敗しました。
mv: `*.deb' を stat できません: そのようなファイルやディレクトリはありません

メッセージ #73637 への返信×

Wiki文法は使えません
ログインしていません。投稿を区別するために投稿者のニックネームをつけてください(ニックネームの一意性は保証されません。全く別の人も同じ名前を利用することが可能ですので本人であることの特定には利用できません。本人であることを保証したい場合にはログインして投稿を行なってください)。 ログインする

Re: IME強化辞書がインストールできない (2014-06-27 15:59 by aztake #73641)

ソースの「doc-ut/ChangeLog」内に以下の文言がありました。

> 2014-06-23
> debian/ は手元に環境がないので更新しない。
> debian/ を debian.old/ にリネーム。

deb系(Debian、Ubuntu等の)ディストリビューションでは動作の保証が出来ないため、
「ビルドするなら自己責任で」という事のようです。

「linuxBean スクリプトの更新」を実行するか、以下の手順でインストール可能になるはずです。

1. 「sudo leafpad /usr/local/bin/bean_pkginst_files/utdict」でスクリプトを開く
2. 51行目付近の「cd ${arc%.*}/」の下に、「mv debian.old debian」と書き加えて保存する
3. 再度設定ウィザードから「IME強化辞書」を実行する
#73637 への返信

メッセージ #73641 への返信×

Wiki文法は使えません
ログインしていません。投稿を区別するために投稿者のニックネームをつけてください(ニックネームの一意性は保証されません。全く別の人も同じ名前を利用することが可能ですので本人であることの特定には利用できません。本人であることを保証したい場合にはログインして投稿を行なってください)。 ログインする

Re: IME強化辞書がインストールできない (2014-06-27 20:24 by inaho #73647)

[メッセージ #73641 への返信]

早速の対応ありがとうございます。

「linuxBean スクリプトの更新」で新しいスクリプトに更新してから実行したところ無事にインストールが完了しました。
実際の修正手順も教えていただき参考になりました。

どうもありがとうございました。
#73641 への返信

メッセージ #73647 への返信×

Wiki文法は使えません
ログインしていません。投稿を区別するために投稿者のニックネームをつけてください(ニックネームの一意性は保証されません。全く別の人も同じ名前を利用することが可能ですので本人であることの特定には利用できません。本人であることを保証したい場合にはログインして投稿を行なってください)。 ログインする

Re: IME強化辞書がインストールできない (2014-06-27 19:31 by loss #73645)

少し気になったので、2点ほど質問を。
・本体の情報が書いてないのですが、まず十分な空き容量はありますでしょうか?
・IMEの変更で「mozc」はインストールしてある状態でしょうか?

横槍失礼しました。
#73637 への返信

メッセージ #73645 への返信×

Wiki文法は使えません
ログインしていません。投稿を区別するために投稿者のニックネームをつけてください(ニックネームの一意性は保証されません。全く別の人も同じ名前を利用することが可能ですので本人であることの特定には利用できません。本人であることを保証したい場合にはログインして投稿を行なってください)。 ログインする

Re: IME強化辞書がインストールできない (2014-06-27 20:36 by inaho #73648)

[メッセージ #73645 への返信]

情報不足への指摘ありがとうございます。
これから気を付けたいと思います。

> ・本体の情報が書いてないのですが、まず十分な空き容量はありますでしょうか?

HDDはl / に8GBの容量を確保して、現在1.7GB程度空いています。

> ・IMEの変更で「mozc」はインストールしてある状態でしょうか?

はい。
先にIMEの変更を行い「mozc」インストールしました。

どうもありがとうございました。
#73645 への返信

メッセージ #73648 への返信×

Wiki文法は使えません
ログインしていません。投稿を区別するために投稿者のニックネームをつけてください(ニックネームの一意性は保証されません。全く別の人も同じ名前を利用することが可能ですので本人であることの特定には利用できません。本人であることを保証したい場合にはログインして投稿を行なってください)。 ログインする