コミットメタ情報

リビジョンc957823b26773b4ff944deb2355428c653c705b8 (tree)
日時2022-07-17 21:48:41
作者matsuand <30614168+matsuand@user...>
コミッターmatsuand

ログメッセージ

[lfsja-git] r11.1-151 対応。

変更サマリ

差分

--- a/configure
+++ b/configure
@@ -4737,7 +4737,7 @@ fi
47374737
47384738
47394739
4740-TARGETVER=r11.1-142
4740+TARGETVER=r11.1-151
47414741 if test "x$revspec" = "xsystemd"; then
47424742 TARGETVER="$TARGETVER-systemd"
47434743 fi
--- a/src/chapter01/changelog.ch
+++ b/src/chapter01/changelog.ch
@@ -44,6 +44,131 @@
4444 @z
4545
4646 @x
47+ <para>2022-07-15</para>
48+ <itemizedlist>
49+ <listitem>
50+ <para>[bdubbs] - Update to meson-0.63.0. Fixes
51+ <ulink url="&lfs-ticket-root;5079">#5079</ulink>.</para>
52+ </listitem>
53+ <listitem>
54+ <para>[bdubbs] - Update to kmod-30. Fixes
55+ <ulink url="&lfs-ticket-root;5077">#5077</ulink>.</para>
56+ </listitem>
57+ <listitem>
58+ <para>[bdubbs] - Update to inetutils-2.3. Fixes
59+ <ulink url="&lfs-ticket-root;5081">#5081</ulink>.</para>
60+ </listitem>
61+ <listitem>
62+ <para>[bdubbs] - Update to linux-5.18.11. Fixes
63+ <ulink url="&lfs-ticket-root;5078">#5078</ulink>.</para>
64+ </listitem>
65+ <listitem>
66+ <para>[bdubbs] - Update to OpenSSL-3.0.5. Fixes
67+ <ulink url="&lfs-ticket-root;5080">#5080</ulink>.</para>
68+ </listitem>
69+ </itemizedlist>
70+@y
71+ <para>2022-07-15</para>
72+ <itemizedlist>
73+ <listitem>
74+ <para>[bdubbs] - meson-0.63.0 へのアップデート。
75+ <ulink url="&lfs-ticket-root;5079">#5079</ulink> を Fix に。</para>
76+ </listitem>
77+ <listitem>
78+ <para>[bdubbs] - kmod-30 へのアップデート。
79+ <ulink url="&lfs-ticket-root;5077">#5077</ulink> を Fix に。</para>
80+ </listitem>
81+ <listitem>
82+ <para>[bdubbs] - inetutils-2.3 へのアップデート。
83+ <ulink url="&lfs-ticket-root;5081">#5081</ulink> を Fix に。</para>
84+ </listitem>
85+ <listitem>
86+ <para>[bdubbs] - linux-5.18.11 へのアップデート。
87+ <ulink url="&lfs-ticket-root;5078">#5078</ulink> を Fix に。</para>
88+ </listitem>
89+ <listitem>
90+ <para>[bdubbs] - OpenSSL-3.0.5 へのアップデート。
91+ <ulink url="&lfs-ticket-root;5080">#5080</ulink> を Fix に。</para>
92+ </listitem>
93+ </itemizedlist>
94+@z
95+
96+@x
97+ <para>2022-07-01</para>
98+ <itemizedlist>
99+ <listitem>
100+ <para>[bdubbs] - Update to vim-9.0.0006. Addresses
101+ <ulink url="&lfs-ticket-root;4500">#4500</ulink>.</para>
102+ </listitem>
103+ <listitem>
104+ <para>[bdubbs] - Update to iana-etc-20220610. Addresses
105+ <ulink url="&lfs-ticket-root;5006">#5006</ulink>.</para>
106+ </listitem>
107+ <listitem>
108+ <para>[bdubbs] - Update to OpenSSL-3.0.4. Fixes
109+ <ulink url="&lfs-ticket-root;5076">#5076</ulink>.</para>
110+ </listitem>
111+ <listitem>
112+ <para>[bdubbs] - Update to kbd-2.5.1. Fixes
113+ <ulink url="&lfs-ticket-root;5075">#5075</ulink>.</para>
114+ </listitem>
115+ <listitem>
116+ <para>[bdubbs] - Update to linux-5.18.8. Fixes
117+ <ulink url="&lfs-ticket-root;5074">#5074</ulink>.</para>
118+ </listitem>
119+ <listitem>
120+ <para>[bdubbs] - Update to bc-5.3.3. Fixes
121+ <ulink url="&lfs-ticket-root;5073">#5073</ulink>.</para>
122+ </listitem>
123+ </itemizedlist>
124+@y
125+ <para>2022-07-01</para>
126+ <itemizedlist>
127+ <listitem>
128+ <para>[bdubbs] - vim-9.0.0006 へのアップデート。
129+ <ulink url="&lfs-ticket-root;4500">#4500</ulink> において言及。</para>
130+ </listitem>
131+ <listitem>
132+ <para>[bdubbs] - iana-etc-20220610 へのアップデート。
133+ <ulink url="&lfs-ticket-root;5006">#5006</ulink> において言及。</para>
134+ </listitem>
135+ <listitem>
136+ <para>[bdubbs] - OpenSSL-3.0.4 へのアップデート。
137+ <ulink url="&lfs-ticket-root;5076">#5076</ulink> を Fix に。</para>
138+ </listitem>
139+ <listitem>
140+ <para>[bdubbs] - kbd-2.5.1 へのアップデート。
141+ <ulink url="&lfs-ticket-root;5075">#5075</ulink> を Fix に。</para>
142+ </listitem>
143+ <listitem>
144+ <para>[bdubbs] - linux-5.18.8 へのアップデート。
145+ <ulink url="&lfs-ticket-root;5074">#5074</ulink> を Fix に。</para>
146+ </listitem>
147+ <listitem>
148+ <para>[bdubbs] - bc-5.3.3 へのアップデート。
149+ <ulink url="&lfs-ticket-root;5073">#5073</ulink> を Fix に。</para>
150+ </listitem>
151+ </itemizedlist>
152+@z
153+
154+@x
155+ <para>2022-06-29</para>
156+ <itemizedlist>
157+ <listitem>
158+ <para>[pierre] - Generate shared C++ bindings for ncurses, instead
159+ of generating and then removing the static ones.</para>
160+ </listitem>
161+ </itemizedlist>
162+@y
163+ <para>2022-06-29</para>
164+ <itemizedlist>
165+ <listitem>
166+ <para>[pierre] - ncurses における C++ バインディングに関して、スタティックなバインディングを生成してから削除するのではなく、共有バインディングを生成することに。</para>
167+ </listitem>
168+ </itemizedlist>
169+@z
170+
171+@x
47172 <para>2022-06-14</para>
48173 <itemizedlist>
49174 <listitem>
--- a/src/chapter01/jchangelog.ch
+++ b/src/chapter01/jchangelog.ch
@@ -50,6 +50,17 @@
5050
5151 -->
5252 <listitem>
53+ <para>2022-07-17</para>
54+ <itemizedlist>
55+ <listitem>
56+ <para>[matsuand] -
57+ r11.1-151 (<ulink url="&lfs-changeset;d060b3354">d060b3354</ulink>) までの対応。
58+ </para>
59+ </listitem>
60+ </itemizedlist>
61+ </listitem>
62+
63+ <listitem>
5364 <para>2022-06-25</para>
5465 <itemizedlist>
5566 <listitem>
--- a/src/chapter06/ncurses.ch
+++ b/src/chapter06/ncurses.ch
@@ -67,6 +67,42 @@
6767 </para>
6868 @z
6969
70+@x --with-shared
71+ <para>This makes Ncurses build and install shared C libraries.</para>
72+@y
73+ <para>
74+ これは Ncurses において共有 C ライブラリをビルドしインストールします。
75+ </para>
76+@z
77+
78+@x --without-normal
79+ <para>This prevents Ncurses building and installing static C
80+ libraries.</para>
81+@y
82+ <para>
83+ これは Ncurses においてスタティックな C ライブラリのビルドおよびインストールを行わないようにします。
84+ </para>
85+@z
86+
87+@x --without-debug
88+ <para>This prevents Ncurses building and installing debug
89+ libraries.</para>
90+@y
91+ <para>
92+ これは Ncurses においてデバッグライブラリのビルドおよびインストールを行わないようにします。
93+ </para>
94+@z
95+
96+@x --with-cxx-shared
97+ <para>This makes Ncurses build and install shared C++ bindings. It
98+ also prevents it building and installing static C++ bindings.</para>
99+@y
100+ <para>
101+ これは Ncurses において共有 C++ バインディングをビルドしインストールします。
102+ 同時にスタティックな C++ バインディングのビルドおよびインストールは行わないようにします。
103+ </para>
104+@z
105+
70106 @x --without-ada
71107 <para>This ensures that Ncurses does not build support for the Ada
72108 compiler which may be present on the host but will not be available
@@ -109,15 +145,6 @@
109145 </para>
110146 @z
111147
112-@x --without-normal
113- <para>This switch disables building and installing most static libraries.
114- </para>
115-@y
116- <para>
117- 本スイッチは、ほとんどのスタティックライブラリをビルドせずインストールもしません。
118- </para>
119-@z
120-
121148 @x
122149 <para>Compile the package:</para>
123150 @y
--- a/src/chapter07/texinfo.ch
+++ b/src/chapter07/texinfo.ch
@@ -22,14 +22,6 @@
2222 @z
2323
2424 @x
25- <para>First, fix an issue building the package with Glibc-2.34 or later:</para>
26-@y
27- <para>
28- Glibc-2.34 以降を使って本パッケージをビルドする際の問題を修正します。
29- </para>
30-@z
31-
32-@x
3325 <para>Prepare Texinfo for compilation:</para>
3426 @y
3527 <para>&PreparePackage1;Texinfo&PreparePackage2;</para>
--- a/src/chapter08/grep.ch
+++ b/src/chapter08/grep.ch
@@ -73,7 +73,7 @@
7373
7474 @x egrep
7575 <para>Prints lines matching an extended regular expression.
76- It is obsoleted, use <command>grep -E</command> instead</para>
76+ It is obsolete, use <command>grep -E</command> instead</para>
7777 @y
7878 <para>
7979 拡張正規表現 (extended regular expression) にマッチした行を表示します。
@@ -83,7 +83,7 @@
8383
8484 @x fgrep
8585 <para>Prints lines matching a list of fixed strings.
86- It is obsoleted, use <command>grep -F</command> instead</para>
86+ It is obsolete, use <command>grep -F</command> instead</para>
8787 @y
8888 <para>
8989 固定文字列の一覧にマッチした行を表示します。
--- a/src/chapter08/ncurses.ch
+++ b/src/chapter08/ncurses.ch
@@ -36,6 +36,51 @@
3636 <title>&MeaningOfOption1;configure&MeaningOfOption2;</title>
3737 @z
3838
39+@x --with-shared
40+ <para>This makes Ncurses build and install shared C libraries.</para>
41+@y
42+ <para>
43+ これは Ncurses において共有 C ライブラリをビルドしインストールします。
44+ </para>
45+@z
46+
47+@x --without-normal
48+ <para>This prevents Ncurses building and installing static C
49+ libraries.</para>
50+@y
51+ <para>
52+ これは Ncurses においてスタティックな C ライブラリのビルドおよびインストールを行わないようにします。
53+ </para>
54+@z
55+
56+@x --without-debug
57+ <para>This prevents Ncurses building and installing debug
58+ libraries.</para>
59+@y
60+ <para>
61+ これは Ncurses においてデバッグライブラリのビルドおよびインストールを行わないようにします。
62+ </para>
63+@z
64+
65+@x --with-cxx-shared
66+ <para>This makes Ncurses build and install shared C++ bindings. It
67+ also prevents it building and installing static C++ bindings.</para>
68+@y
69+ <para>
70+ これは Ncurses において共有 C++ バインディングをビルドしインストールします。
71+ 同時にスタティックな C++ バインディングのビルドおよびインストールは行わないようにします。
72+ </para>
73+@z
74+
75+@x --enable-pc-files
76+ <para>This switch generates and installs .pc files for pkg-config.
77+ </para>
78+@y
79+ <para>
80+ 本スイッチは pkg-config 用の .pc ファイルを生成しインストールすることを指示します。
81+ </para>
82+@z
83+
3984 @x --enable-widec
4085 <para>This switch causes wide-character libraries (e.g., <filename
4186 class="libraryfile">libncursesw.so.&ncurses-version;</filename>)
@@ -56,24 +101,6 @@
56101 </para>
57102 @z
58103
59-@x --enable-pc-files
60- <para>This switch generates and installs .pc files for pkg-config.
61- </para>
62-@y
63- <para>
64- 本スイッチは pkg-config 用の .pc ファイルを生成しインストールすることを指示します。
65- </para>
66-@z
67-
68-@x --without-normal
69- <para>This switch disables building and installing most static libraries.
70- </para>
71-@y
72- <para>
73- 本スイッチはたいていのスタティックライブラリをビルド、インストールしないようにします。
74- </para>
75-@z
76-
77104 @x
78105 <para>Compile the package:</para>
79106 @y
--- a/src/chapter08/openssl.ch
+++ b/src/chapter08/openssl.ch
@@ -29,6 +29,15 @@
2929 @z
3030
3131 @x
32+ <para>First fix a problem with some advanced arcitectures with avx512
33+ capability:</para>
34+@y
35+ <para>
36+ avx512 機能を利用する最新アーキテクチャーにおいて発生する問題を修正します。
37+ </para>
38+@z
39+
40+@x
3241 <para>Prepare OpenSSL for compilation:</para>
3342 @y
3443 <para>&PreparePackage1;OpenSSL&PreparePackage2;</para>
--- a/src/chapter08/python.ch
+++ b/src/chapter08/python.ch
@@ -92,7 +92,7 @@
9292 @z
9393
9494 @x
95- <para>In serveral places we use the <command>pip3</command> command to
95+ <para>In several places we use the <command>pip3</command> command to
9696 install Python 3 programs and modules for all users as
9797 <systemitem class='username'>root</systemitem>. This conflicts
9898 with the Python developers recommendation to install packages into a
@@ -137,12 +137,13 @@
137137 command to upgrade a module (for example, from meson-0.61.3 to
138138 meson-0.62.0), insert the option <parameter>--upgrade</parameter> into
139139 the command line. If it's really necessary to downgrade a module or
140- reinstall the same version for some reason, insert
141- <parameter>--force-reinstall</parameter> into the command line.
140+ reinstall the same version for some reason, insert
141+ <parameter>--force-reinstall --no-deps</parameter> into the command
142+ line.
142143 @y
143144 <command>pip3 install</command> はデフォルトでは、すでにインストールされているモジュールを再インストールすることは行いません。
144145 <command>pip3 install</command> コマンドを使ってモジュールのアップグレードを行う(たとえば meson-0.61.3 から meson-0.62.0 にするような場合)には、コマンドラインに <parameter>--upgrade</parameter> オプションを含めてください。
145- またモジュールのダウングレードや再インストールが必要となる理由が確実にあるのであれば、コマンドラインに <parameter>--force-reinstall</parameter> を含めて実行してください。
146+ またモジュールのダウングレードや再インストールが必要となる理由が確実にあるのであれば、コマンドラインに <parameter>--force-reinstall --no-deps</parameter> を含めて実行してください。
146147 @z
147148
148149 @x
--- a/src/chapter08/texinfo.ch
+++ b/src/chapter08/texinfo.ch
@@ -53,14 +53,6 @@
5353 @z
5454
5555 @x
56- <para>Again, fix an issue building the package with Glibc-2.34 or later:</para>
57-@y
58- <para>
59- 以前と同じように、Glibc-2.34 以降を使って本パッケージをビルドする際の問題を修正します。
60- </para>
61-@z
62-
63-@x
6456 <para>Compile the package:</para>
6557 @y
6658 <para>&CompileThePackage;</para>
--- a/src/general.ch
+++ b/src/general.ch
@@ -47,9 +47,9 @@
4747 <!ENTITY copyrightdate "%crdate;">
4848 ]]>
4949
50-<!ENTITY jversion "20220625">
51-<!ENTITY jversiond "20220625">
52-<!ENTITY jcorrespondSHA "bfc649552"> <!-- lfs-git SHA 値; 本箇所での記載のみ -->
50+<!ENTITY jversion "20220717">
51+<!ENTITY jversiond "20220717">
52+<!ENTITY jcorrespondSHA "d060b3354"> <!-- lfs-git SHA 値; 本箇所での記載のみ -->
5353 <!ENTITY dir-jversion "git-ja">
5454 <!ENTITY dir-jversiond "git-sysdja">
5555 @z
--- a/version.ac
+++ b/version.ac
@@ -2,4 +2,4 @@ dnl
22 dnl This is part of LFSbookja package.
33 dnl
44 dnl m4-include this file to define the current LFS version
5-m4_define([lfs_version], [r11.1-142])
5+m4_define([lfs_version], [r11.1-151])
旧リポジトリブラウザで表示