チケット #40045

GCCで発生する警告を修正

登録: 2020-02-21 01:27 最終更新: 2020-08-22 01:12

報告者:
担当者:
チケットの種類:
状況:
オープン [担当者決定済み]
コンポーネント:
(未割り当て)
マイルストーン:
優先度:
5 - 中
重要度:
5 - 中
解決法:
なし
ファイル:
なし

詳細

Habuさんから以前より再三指摘された件をチケット化。

提案していただいた曰く、gccで”env CFLAGS="-Wall -Wno-format-overflow" を指定して./configureしてmakeした時にwarningゼロにしておきたい。format-overflowの警告は正直あまりにも面倒くさいので、なしにしたい、とのこと。

チケットの履歴 (3 件中 3 件表示)

2020-02-21 01:27 更新者: deskull
  • 新しいチケット "GCCで発生する警告を修正" が作成されました
2020-02-22 00:21 更新者: hourier
コメント

Ubuntu 18.04.4 で実施し、警告を除去しました

リリース前にもう1回実施して、問題なければクローズしましょう!

2020-08-22 01:12 更新者: deskull
コメント

本日再確認しましたがまだそれなりに出ています。こちらが手を加えた分も含めてもうしばらく保留します。

添付ファイルリスト

添付ファイルはありません

編集

ログインしていません。ログインしていない状態では、コメントに記載者の記録が残りません。 » ログインする