ダウンロードリスト

Sponsored link

プロジェクト概要

Antは、make に似た Java ベースのビルドツールで、クロスプラットフォームのJava開発をよりよくサポートします。これは Apache の多くのプロジェクトをはじめ、各種のオープンソース Java プロジェクトで採用されています。

システム要件

システム要件が設定されていません
プロジェクトのリリース情報やプロジェクトリソースの情報です。
注: プロジェクトリソースの情報は Freecode.com ページからの引用です。ダウンロードそのものは、OSDNにホスティングされているものではありません。

2012-03-01 23:14
1.8.3

いくつかの小さな修正と改善の多くのタスクの間で。
Several small fixes and improvements across many tasks.

2010-12-28 07:48
1.8.2

ディレクトリ内のパフォーマンスの向上は、スキャン。 XSLTのタスク名誉再びパス(bugrep 49271)。コアタスクとオプションタスクの区別は廃止されています。多数のバグ修正や改良は、Bugzillaにと入っているWhatsNewで説明しています。
Performance improvements in directory scanning. The XSLT task honors the classpath again (bugrep 49271). The distinction between core tasks and optional tasks is abolished. Numerous bugfixes and improvements as documented in Bugzilla and in WHATSNEW.

2010-05-08 18:42
1.8.1

新しいタスクが増強、ユーザーが以前に定義した参照する属性またはネストされた要素を追加することができます。多数のバグ修正と改善が、としてBugzillaに文書化し、年01月。ファイルで行われた。
New task augmenting allows users to add attributes or nested elements to previously defined references. Numerous bugfixes and improvements were made, as documented in Bugzilla and in the WHATSNEW file.

2010-02-09 16:06
1.8.0

レキシカルスコープローカルのプロパティが追加されました。 <import>今、任意のファイルから、またはURLのリソースを提供するインポートすることができます。ディレクトリのコードをスキャンする様々な改良スキャンのパフォーマンスが改善された。その他多数のバグ修正と改善された。
Lexically scoped local properties were added. <import> can now import from any file- or URL-providing resource. Various improvements to the directory scanning code improved scanning performance. There were numerous other bugfixes and improvements.

2010-01-13 17:38
1.8.0RC1

新しい最上位レベルの要素は、拡張ポイント、ファイルをビルドするカスタムターゲットをより簡単に拡張することができます。 "if"と"しない"属性のプロパティを入力した値をする場合、これらのプロパティを、オンまたはオフに虚偽がtrueに評価を合わせて評価されます。 AntをすぐにJava 1.4以降が必要です。新しいタスク、を含む代替案を提供する<import>そのときに任意のターゲットを無効にしない方が望ましい。多数のバグ修正や改良が行われた。
A new top level element, extension-point, allows build files to be extended with custom targets more easily. The "if" and "unless" attributes will be evaluated according to the values of the properties entered if these properties evaluate to true, false, on, or off. Ant now requires Java 1.4 or later. A new task, include, provides an alternative to <import> that should be preferred when you don't want to override any targets. Numerous bugfixes and improvements were made.

プロジェクトリソース