チケット #43362

Meson: Bump minimum meson requirement to 0.57.0 for Qt6 module

登録: 2021-12-09 18:23 最終更新: 2022-05-15 03:54

報告者:
担当者:
チケットの種類:
状況:
完了
コンポーネント:
マイルストーン:
優先度:
5 - 中
重要度:
5 - 中
解決法:
修正済み
ファイル:
2

詳細

Qt6 module is available since meson version 0.57.0. Make that the minimum requirement, so we can add Qt6 support (in a separate ticket)

As part of #43200, this has also been posted to http://forum.freeciv.org/f/viewtopic.php?f=14&t=92096

チケットの履歴 (12 件中 3 件表示)

2021-12-09 18:23 更新者: cazfi
  • 新しいチケット "Meson: Bump minimum meson requirement to 0.57.0 for Qt6 module" が作成されました
2021-12-09 18:32 更新者: cazfi
コメント

Reply To cazfi

we can add Qt6 support (in a separate ticket)

-> #43364

2021-12-10 02:20 更新者: cazfi
  • 詳細が更新されました
2022-01-05 09:05 更新者: cazfi
  • 解決法なし から 受領 に更新されました
2022-01-11 19:26 更新者: cazfi
コメント

CI currently does meson build with older version. That needs to be resolved before this patch can go forward.

One option is to simply wait that CI can be switched to use ubuntu-22.04 (-> #43598)

2022-01-12 00:22 更新者: cazfi
  • 解決法受領 から なし に更新されました
コメント

Will need rebasing when it's time to apply this.

2022-04-28 09:31 更新者: cazfi
コメント

This will also enable #42935

2022-04-28 16:57 更新者: cazfi
コメント

Reply To cazfi

One option is to simply wait that CI can be switched to use ubuntu-22.04 (-> #43598)

The other option is installing new meson to existing system (-> #44477)

2022-05-06 10:09 更新者: cazfi
  • 担当者(未割り当て) から cazfi に更新されました
  • 解決法なし から 受領 に更新されました
コメント

Reply To cazfi

Will need rebasing when it's time to apply this.

Rebased

2022-05-15 03:54 更新者: cazfi
  • 状況オープン から 完了 に更新されました
  • 解決法受領 から 修正済み に更新されました

編集

ログインしていません。ログインしていない状態では、コメントに記載者の記録が残りません。 » ログインする