2018-04-20 11:33 (by okkez)

Cutter

Improvements
  • deb Supported Debian stretch. Debian wheezy supported was dropped.
  • Supported LCOV 1.12 and 1.13.
  • Added missing GPLv3 text. by tSU_RooT
  • debubuntu Supported Ubuntu 16.04 and 17.04. Ubuntu 12.04 (precise) and 15.04 (vivid) support was dropped.
  • travis Fixed to use https in setup.sh for APT.
  • travis Supported to use CODE_NAME environment variable for installing cutter package on Debian sid. Use "env CODE_NAME=unstable setup.sh" on Debian sid.
  • Changed to use recommended Unicode characters in translatable strings since GLib 2.52.0.
  • Dropped CentOS 5 support.
Fixes

CppCutter

Fixes
  • GitHub#23 Fixed a bug that inline instance method in destructor causes invalid UTF-8 assertion warning message.

cut-diff

Improvements
  • Invert deleted and inserted colors. Now red means inserted segment, green means deleted segment.

Thanks

  • tSU_RooT
  • Hiroshi Ohkubo
  • Hideki Yamane
Cutterプロジェクトのニュース一覧