フォーラム: ヘルプ (スレッド #22883)

cross compile help (2009-05-28 01:20 by pete #44032)

Hello,

I am trying to get Anthy and UIM to cross compile on an ARM processor. I can configure it correctly as I have done a bunch of other libs to work on this processor using my tool-chain. But when I go to make, Anthy fails with an error as such ...

...
Making all in depgraph
make[2]: Entering directory `/utilities/uim/anthy-9100h/depgraph'
if arm_v5t_le-gcc -DHAVE_CONFIG_H -I. -I. -I.. -I../ -DSRCDIR=\".\" -I/opt/montavista/common/include -O2 -W -Wall -Wwrite-strings -Wstrict-prototypes -Wmissing-prototypes -pedantic -Wno-long-long -MT mkdepgraph.o -MD -MP -MF ".deps/mkdepgraph.Tpo" -c -o mkdepgraph.o mkdepgraph.c; \
then mv -f ".deps/mkdepgraph.Tpo" ".deps/mkdepgraph.Po"; else rm -f ".deps/mkdepgraph.Tpo"; exit 1; fi
mkdepgraph.c:426: warning: unused parameter 'argc'
mkdepgraph.c:426: warning: unused parameter 'argv'
/bin/sh ../libtool --tag=CC --mode=link arm_v5t_le-gcc -O2 -W -Wall -Wwrite-strings -Wstrict-prototypes -Wmissing-prototypes -pedantic -Wno-long-long -L/opt/montavista/pro/lib -o mkdepgraph mkdepgraph.o ../src-main/libanthy.la ../src-worddic/libanthydic.la
mkdir .libs
arm_v5t_le-gcc -O2 -W -Wall -Wwrite-strings -Wstrict-prototypes -Wmissing-prototypes -pedantic -Wno-long-long -o .libs/mkdepgraph mkdepgraph.o -L/opt/montavista/pro/lib ../src-main/.libs/libanthy.so ../src-worddic/.libs/libanthydic.so -Wl,--rpath -Wl,/usr/local/lib
creating mkdepgraph
./mkdepgraph
./mkdepgraph: line 105: /utilities/uim/anthy-9100h/depgraph/.libs/lt-mkdepgraph: cannot execute binary file
./mkdepgraph: line 105: /utilities/uim/anthy-9100h/depgraph/.libs/lt-mkdepgraph: Success
make[2]: *** [anthy.dep] Error 1
make[2]: Leaving directory `/utilities/uim/anthy-9100h/depgraph'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/utilities/uim/anthy-9100h'
make: *** [all] Error 2
[root@localhost anthy-9100h]#

Here is my configure and it does show me that it is cross compiling ...

./configure --enable-shared \
--host=i686-pc-linux-gnu \
--target=armv5tl-montavista-linuxeabi \
--build=armv5tl-montavista-linuxeabi \
build_alias=armv5tl-montavista-linuxeabi \
host_alias=i686-pc-linux-gnu \
target_alias=armv5tl-montavista-linuxeabi \
CC=arm_v5t_le-gcc \
CXX=arm_v5t_le-g++ \
CFLAGS=-O2 \
CPPFLAGS=-O2 \
CPPFLAGS=-I/opt/montavista/pro/devkit/arm/v5t_le/target/usr/include \
CPPFLAGS=-I/opt/montavista/pro/devkit/arm/v5t_le/include \
CPPFLAGS=-I/opt/montavista/pro/include \
CPPFLAGS=-I/opt/montavista/common/include \
LDFLAGS=-L/opt/montavista/pro/devkit/arm/v5t_le/target/lib \
LDFLAGS=-L/opt/montavista/pro/devkit/arm/v5t_le/lib \
LDFLAGS=-L/opt/montavista/common/lib \
LDFLAGS=-L/opt/montavista/pro/lib

I'm sorry that I don't understand Japanese.

Any help is greatly appreciated. Have a good day.

Cheers,
Pete