チケット #28940

Amateras UML to work with java 7

登録: 2012-07-08 06:04 最終更新: 2012-07-17 00:04

報告者:
担当者:
チケットの種類:
状況:
完了
コンポーネント:
マイルストーン:
(未割り当て)
優先度:
5 - 中
重要度:
5 - 中
解決法:
修正済み
ファイル:
なし

詳細

Hi. Amateras UML breaks when using java 7 + eclipse. I can see the information of the diagrams elements if I open it as text. But when I open it as diagram, it renders a white page.
I really liked the tool, but this is a deal breaker!
Thanks a lot in advance!
Best regards,
Ricardo

チケットの履歴 (15 件中 3 件表示)

2012-07-08 06:04 更新者: rvmfonseca
  • 新しいチケット "Amateras UML to work with java 7" が作成されました
2012-07-09 02:00 更新者: takezoe
  • 担当者(未割り当て) から takezoe に更新されました
コメント

Thanks for your feedback.

I want some more information for testing in my environment. What version of Eclipse are you using?

2012-07-09 02:55 更新者: rvmfonseca
コメント

Hi. Here follows the requeste info:

Eclipse Version: Indigo Service Release 2 Build id: 20120216-1857

JDK 7

Plugin details: Project Amateras UML Plugin 1.3.3 Project Amateras UML Java Generator Plug-in 1.3.3

2012-07-09 12:11 更新者: takezoe
コメント

Sorry, I have one more question. Are your JDK and Eclipse 64 bit version?

2012-07-09 12:50 更新者: rvmfonseca
コメント

Reply To takezoe

Sorry, I have one more question. Are your JDK and Eclipse 64 bit version?

Sure, no problem. Ask as many questions as you need.
- Windows Vista Home Premium 64 bits
- java.version=1.7.0_04; java.vm.name=Java HotSpot(TM) 64-Bit Server VM
- Eclipse

--launcher.library D:\programacao\java\ide\eclipse3.7\\plugins/org.eclipse.equinox.launcher.win32.win32.x86_64_1.1.100.v20110502\eclipse_1406.dll

So I believe the answer is yes. Both are 64 bit. I could find some people in the forums with the same problem. They said that when they changed to java 6 the problem was solved. But this is not an option for me. Reference: http://sourceforge.jp/forum/forum.php?forum_id=3586&thread_id=30216
Thanks
2012-07-09 13:39 更新者: takezoe
コメント

Thanks, I'll investigate.

2012-07-14 04:31 更新者: takezoe
コメント

I put AmaterasUML 1.3.3 which is compiled by JDK 1.7 into the following URL: http://amateras.sourceforge.jp/files/amaterasuml/

It worked with 64bit version of JDK 1.7 and Indigo in my environment. Coukd you try it?

2012-07-14 05:54 更新者: rvmfonseca
コメント

Reply To takezoe

I put AmaterasUML 1.3.3 which is compiled by JDK 1.7 into the following URL: http://amateras.sourceforge.jp/files/amaterasuml/ It worked with 64bit version of JDK 1.7 and Indigo in my environment. Coukd you try it?

Hi.

It didn't work :(

I tried 2 times. First I closed eclipse, deleted the original jars, put the new ones there and restarted eclipse.

Then I closed eclipse, removed the jars, opened eclipse (it couldn't read the .cld), closed it, put the new jars again, but the problem persisted.

You said it worked at your place, right? Maybe it's some external dependency... I have a subversion plugin and a javafx plugin installed. This weekend I'll try with a fresh Eclipse installation and will let you know.

Thanks!

2012-07-15 04:06 更新者: rvmfonseca
コメント

Reply To rvmfonseca

Reply To takezoe

I put AmaterasUML 1.3.3 which is compiled by JDK 1.7 into the following URL: http://amateras.sourceforge.jp/files/amaterasuml/ It worked with 64bit version of JDK 1.7 and Indigo in my environment. Coukd you try it?

Hi. It didn't work :( I tried 2 times. First I closed eclipse, deleted the original jars, put the new ones there and restarted eclipse. Then I closed eclipse, removed the jars, opened eclipse (it couldn't read the .cld), closed it, put the new jars again, but the problem persisted. You said it worked at your place, right? Maybe it's some external dependency... I have a subversion plugin and a javafx plugin installed. This weekend I'll try with a fresh Eclipse installation and will let you know. Thanks!

Hi again. I tried with a brand new installation of Eclipse Indigo but the outcome was the same. I can create and edit the diagram but after I close it, it renders a white page when I try to reopen it, even though the diagram elements are there (I can see it when I open the diagram as text).

Could you really make it work with this version you let available for download?

Best regards, Ricardo

2012-07-15 15:10 更新者: takezoe
コメント

Hi Recardo,

Sorry, I couldn't fix a problem correctly in the previous uploaded plug-in.
I updated a plug-in again, please try it:
http://amateras.sourceforge.jp/files/amaterasuml/AmaterasUML1.3.3.20120715.zip

2012-07-15 21:20 更新者: rvmfonseca
コメント

Reply To takezoe

Hi Recardo, Sorry, I couldn't fix a problem correctly in the previous uploaded plug-in.
I updated a plug-in again, please try it:
http://amateras.sourceforge.jp/files/amaterasuml/AmaterasUML1.3.3.20120715.zip

Hi! It worked! Thanks a lot!

Is that link something official which I can tell the other guys they can use?

Best regards,

Ricardo

2012-07-16 10:57 更新者: takezoe
コメント

rvmfonseca への返信

Is that link something official which I can tell the other guys they can use?

This is a development version. It needs more test and some additional changes might be added in the next release.

So we can't recommend to use the development version but of course, your feedback for the development version is welcome.

Anyway, we'll release AmaterasUML 1.3.4 as soon as possible.

2012-07-16 11:01 更新者: rvmfonseca
  • チケット完了時刻2012-07-16 11:01 に更新されました
  • 状況オープン から 完了 に更新されました
  • 解決法なし から 修正済み に更新されました
コメント

Reply To takezoe

rvmfonseca への返信

Is that link something official which I can tell the other guys they can use?

This is a development version. It needs more test and some additional changes might be added in the next release. So we can't recommend to use the development version but of course, your feedback for the development version is welcome. Anyway, we'll release AmaterasUML 1.3.4 as soon as possible.

Ok, thank you again. I'm closing this ticket. I'll let you know if I can think about any useful feedback

2012-07-16 23:39 更新者: takezoe
コメント

Hi Recardo,

I found a actual reason of this problem. It's caused by old version of XStream. I replaced it to the latest version of XStream. Then problem was resolved.

The development version that is uploaded by me yesterday breaks compartibility of file format. So I will roll back this fix and release 1.3.4 with the latest version of XStream.

Again, don't use the development version in production. Please wait for the next release. I will release as soon as possible.

2012-07-17 00:04 更新者: takezoe
コメント

Hi Recardo,

We released AmaetrasUML 1.3.4 just now. Please use it instead of the development version: http://sourceforge.jp/projects/amateras/downloads/56447/AmaterasUML_1.3.4.zip/

添付ファイルリスト

添付ファイルはありません

編集

このチケットにコメントを追加するには、ログインが必要です » ログインする